波段趋势副图

  • A+
所属分类:博弈大师

指标代码及说明:

VAR2:=CLOSE*VOL;

MID:=EMA((EMA(VAR2,3)/EMA(VOL,3)+EMA(VAR2,6)/EMA(VOL,6)+EMA(VAR2,12)/EMA(VOL,12)+EMA(VAR2,24)/EMA(VOL,24))/4,N);

主趋势线1:MID;MID2:=MID*1.01;

SDN:=MID*0.94;

SDN3:=REF(CLOSE,1800),COLORYELLOW;

SUP:=1.06*MID,COLORBLUE;

VAR4:=EMA(CLOSE,9);

B9:=COUNT(HIGH>SUP,5);

VAR1:=MID;

PARTLINE(VAR1>REF(VAR1,1),VAR1),LINETHICK2,COLORRED;

PARTLINE(VAR1<REF(VAR1,1),VAR1),LINETHICK2,COLORCYAN;

PP:=(2*CLOSE+HIGH+LOW)/4;

QQ:=ABS(PP-MA(CLOSE,N*15));

AA:=QQ/MA(CLOSE,N*15);

N2:=(N-2)*15;

N3:=(N+2)*15;

N4:=(N+3)*15;

主趋势线:=(MA(CLOSE,13)),LINETHICK2,COLORRED;

CC:=(CLOSE/主趋势线);

MA1:=MA(CC*(2*CLOSE+HIGH+LOW)/4,3);

MAAA:=((MA1-主趋势线)/主趋势线)/3;

TMP:=MA1-MAAA*MA1;

短期趋势线:TMP,LINETHICK2,COLORYELLOW;

PARTLINE(TMP<=MID,MID),LINETHICK2,COLORCYAN;

PARTLINE(TMP<=REF(TMP,1),TMP),LINETHICK2,COLORWHITE;

PARTLINE(TMP<=MID,TMP),LINETHICK2,COLORGREEN;

PARTLINE(TMP>=REF(TMP,1) AND TMP<MID,TMP),LINETHICK2,COLOR000080;

MA3:=MA(CLOSE,3);

MA7:=MA(CLOSE,7);

MA14:=MA(CLOSE,14);

RED:=CROSS(C,MA14);

GREEN:=CROSS(MA14,C);

FLAG:=IF(BARSTATUS=1,0,IF(RED,1,IF(GREEN,-1,REF(FLAG,1))));

STICKLINE(FLAG>0,HIGH,MAX(C,O),0,1),COLORRED;

STICKLINE(FLAG>0,LOW,MIN(C,O),0,1),COLORRED;

STICKLINE(FLAG>0,C,O,4,1),COLORRED;

STICKLINE(FLAG<0,HIGH,MAX(C,O),0,0),COLORGREEN;

STICKLINE(FLAG<0,LOW,MIN(C,O),0,0),COLORGREEN;

STICKLINE(FLAG<0,C,O,4,0),COLORGREEN;

STICKLINE(FLAG=0,HIGH,MAX(C,O),0,0),COLORYELLOW;

STICKLINE(FLAG=0,LOW,MIN(C,O),0,0),COLORYELLOW;

STICKLINE(FLAG=0,C,O,4,0),COLORYELLOW;

DRAWICON(FLAG>0 AND CROSS(MA3,MA7),LOW,4),VALIGN0;

DRAWICON(FLAG<0 AND CROSS(MA7,MA3),HIGH,5),VALIGN2;

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: