精准撑压 发公式----

  • A+
所属分类:大智慧公式

指标代码及说明:

其实这个图作为主图 是很直观的,但是如果把他作为股票池的选股公式。你肯定会有意想不到的收获。它有几种不同的设置---也就是突破股票的几个压力位置。我已经说的清清楚楚,如果你用此公式在做不好股票池。我就无话可说了。 有人说通不过。我说莫名奇妙。我用的好好的啊。那位朋友说一下 他只是个啥情况???另外 我说一下 :重要的设置 是 《工作1》 这条线的设置 不太明白的人 你先好好研究一下图。琢磨琢磨应该怎么样设置。本来我就不想说的太详细,我感觉 说的太详细,好像没有什么好处。

精准撑压

input: N(5,1,100);A1:=ref(h,N)=hhv(h,2*N+1);B1:=filter(A1,N);C1:=backset(B1,N+1);D1:=filter(C1,n);{高点}A2:=ref(l,N)=llv(l,2*N+1);B2:=filter(A2,N);C2:=backset(B2,N+1);D2:=filter(C2,N);{低点}E1:=(ref(llv(l,2*N),1)+ref(hhv(h,2*N),1))/2; E2:=(h+l)/2;{高低点出现在同一K线上时可作取舍}H1:=(D1 AND not(D2 AND E1>=E2)) OR barstatus=2 OR barscount(c)=1;L1:=(D2 AND not(D1 AND E1<E2)); H2:=D1 AND not(D2 AND E1>=E2);X1:=ref(barslast(H1),1)+1; F1:=backset(H1 AND count(L1,X1)>0,llvbars(if(L1,l,10000),X1));G1:=F1>ref(F1,1); I1:=backset(G1,2); LD:=I1>ref(I1,1);{过滤后低点}L2:=LD OR barstatus=2 OR barscount(c)=1;X2:=ref(barslast(L2),1)+1; F2:=backset(L2 AND count(H2,X2)>0,hhvbars(if(H2,h,0),X2));G2:=F2>ref(F2,1); I2:=backset(G2,2); HD:=I2>ref(I2,1);{过滤后高点}R1:=backset(barstatus=2,barslast(HD)+1); S1:=R1>ref(R1,1); {前一高}T1:=backset(barstatus=2,barslast(LD)+1); U1:=T1>ref(T1,1); {前一低}R2:=backset(S1,ref(barslast(HD),1)+2); S2:=R2>ref(R2,1); {前二高}T2:=backset(U1,ref(barslast(LD),1)+2); U2:=T2>ref(T2,1); {前二低}

压力:drawline(S2,h,S1,h,1),Colorred;支撑:drawline(U2,l,U1,l,1),Colorgreen;HH1:=if(s2,H,ref(H,BARSLAST(s2)));HH2:=if(s1,H,ref(H,BARSLAST(s1)));LL1:=if(u2,l,ref(l,BARSLAST(u2)));LL2:=if(u1,l,ref(l,BARSLAST(u1)));平台:HH2+(HH1-LL1)*BARSLAST(E2)/(BARSLAST(s2)-BARSLAST(s1));上压:HH1+(HH2-HH1)*BARSLAST(s2)/(BARSLAST(s2)-BARSLAST(s1));下支:LL1+(LL2-LL1)*BARSLAST(U2)/(BARSLAST(U2)-BARSLAST(u1));工作1:eMA(CLOSE,1),colorFF00FF,linethick1;二号111:eMA(CLOSE,111),colorred;三号166:eMA(CLOSE,179),colorgreen;四号256:eMA(CLOSE,256),COLORGRAY,Linethick2;生命433:eMA(CLOSE,433),Color2F2F6F,linethick2;VAR1:=SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),25);VAR2:=HIGH-REF(HIGH,1);VAR3:=REF(LOW,1)-LOW;VAR4:=SUM(IF(VAR2>0 AND VAR2>VAR3,VAR2,0),25);VAR5:=SUM(IF(VAR3>0 AND VAR3>VAR2,VAR3,0),25);VAR6:=VAR4*100/VAR1;VAR7:=VAR5*100/VAR1;VAR8:=MA(ABS(VAR7-VAR6)/(VAR7+VAR6)*100,15);VAR9:=(VAR8+REF(VAR8,15))/2;A:=(VAR7>VAR6 AND VAR7>25 AND VAR6<25);B:=ZIG(3,5)*100;G:=MA(B,2);D:=CROSS(B,G);W:=CROSS(G,B);E:=REF(INDEXC,1);F:=SMA(MAX(INDEXC-E,0),3,1)/SMA(ABS(INDEXC-E),3,1);VAR10:=F AND F<8;VAR11:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;VAR12:=SMA(VAR11,3,1);VAR13:=SMA(VAR12,3,1);VAR14:=VAR13 AND VAR13<20;DRAWTEXT(FILTER(D=1,5),LOW-0.1,'↖买'),COLORYELLOW;DRAWTEXT(W=1,HIGH*1.02,'逃'),COLORGREEN;STICKLINE(w=1,o,c,3,0),COLORBLUE;STICKLINE(D=1,o,c,3,0),COLORYELLOW;

DRAWTEXTABS(2,5,'当突破压力位时 《尾盘回调最好》《突破上压后,回调到下支撑买入》'),COLORFF50FF,linethick1;

DRAWTEXTABS(2,25,'<突破平台最好> 站稳 就可买 《关键是趋势向上》收盘价突破453时二天回抽时买入跌破453时候'),COLORFF50FF,linethick1;

DRAWTEXTABS(2,45,'坚决在反抽的时候卖出碰过9号密码线(收盘价尤佳),那么再回到25线就是难得的买入点再突破9号线,'),COLORFF50FF,linethick1;

DRAWTEXTABS(2,65,'应有30%的涨幅收盘价突破453时第二天回抽时买入跌破453时候坚决在反抽的时候卖出所属板块:'+BKNAME),COLORFF50FF,linethick1;

DRAWTEXTABS(2,85,'坚决在反抽的时候卖出所属板块:'+BKNAME),COLORFF50FF,linethick1;

VAR3:=LLV(HIGH,240);VAR4:=100*(CLOSE-VAR3)/VAR3;VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;VAR7:=0;VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);买1:=VAR10;买2:=(VAR11+VAR13+VAR15+VAR17);卖1:=(VAR12+VAR14+VAR16+VAR18);DRAWTEXT(买1>0 OR 买2>0,LOW*0.99,'←买入'),CROSSDOT,LINETHICK1,COLORRED;DRAWTEXT(卖1>0,HIGH*1.02,'←卖出'),CROSSDOT,LINETHICK1,COLORGREEN;VAR100:=(100 - ((90 * (HHV(HIGH,20) - CLOSE)) / (HHV(HIGH,20) - LLV(LOW,20))));VAR200:=(100 - ((90 * (HHV(HIGH,20) - CLOSE)) / (HHV(HIGH,20) - LLV(LOW,20))));VAR300:=(100 - MA(((100 * (HHV(HIGH,5) - CLOSE)) / (HHV(HIGH,5) - LLV(LOW,5))),34));

指标效果图:

精准撑压 发公式-----1

指标效果图:

精准撑压 发公式-----2

指标下载地址:

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: