综合判断分析

  • A+
所属分类:飞狐公式

指标代码及说明:

AAA:=(MA(CLOSE,13)+MA(CLOSE,17))/2;

CCC:=(STD(CLOSE,13)+STD(CLOSE,17))/2;

BBB:=AAA+2.1*CCC;

DDD:=AAA+0.72*CCC;

ZZZ:=IF(CCC>1.88,MA(DDD,3),DDD);

平仓:ZZZ*1.145,LINETHICK1,colorFFFF00;

风险:ZZZ*1.095,LINETHICK1,colorFF00;

回档:ZZZ*1.04,LINETHICK1,colorFFFF;

平衡:ZZZ*0.986,LINETHICK1,colorFFFFFF;

反弹:ZZZ*0.918,LINETHICK1,colorFF00FF;

超低:ZZZ*0.88,LINETHICK1,colorFF;

满仓:ZZZ*0.83,LINETHICK2,colorFF0000;

YB:=SYSPARAM(2);

A:=SYSPARAM(3);

P:=A-YB;

S4:=SYSPARAM(4);

S5:=SYSPARAM(5);

HH:=HHVBARS(HIGH,P+1);

LL:=LLVBARS(LOW,P+1);

Z:=BARPOS=A-HH[A];

Y:=BARPOS=A-LL[A];

K:=(S4-S5)/(A-YB);

DRAWSL(Z,HIGH,-15*K/60,0,0),POINTDOT,colorFFFF00;

DRAWSL(Z,HIGH,-30*K/60,0,0),POINTDOT,colorFFFF00;

DRAWSL(Z,HIGH,-45*K/60,0,0),POINTDOT,colorFFFF00;

DRAWSL(Z,HIGH,-60*K/60,0,0),colorFFFF00;

DRAWSL(Z,HIGH,-85*K/60,0,0),POINTDOT,colorFFFF00;

DRAWSL(Z,HIGH,-120*K/60,0,0),POINTDOT,colorFFFF00;

DRAWSL(Z,HIGH,-165*K/60,0,0),POINTDOT,colorFFFF00;

DRAWSL(Z,HIGH,-240*K/60,0,0),POINTDOT,colorFFFF00;

DRAWSL(Z,HIGH,-360*K/60,0,0),POINTDOT,colorFFFF00;

DRAWSL(Z,HIGH,-600*K/60,0,0),POINTDOT,colorFFFF00;

DRAWSL(Y,LOW,10*K/60,0,0),POINTDOT,colorFF00FF;

DRAWSL(Y,LOW,30*K/60,0,0),POINTDOT,colorFF00FF;

DRAWSL(Y,LOW,60*K/60,0,0),POINTDOT,colorFF00FF;

DRAWSL(Y,LOW,90*K/60,0,0),POINTDOT,colorFF00FF;

DRAWSL(Y,LOW,120*K/60,0,0),colorFF00FF;

DRAWSL(Y,LOW,180*K/60,0,0),POINTDOT,colorFF00FF;

DRAWSL(Y,LOW,300*K/60,0,0),POINTDOT,colorFF00FF;

DRAWSL(Y,LOW,540*K/60,0,0),POINTDOT,colorFF00FF;

DRAWSL(Y,LOW,1020*K/60,0,0),POINTDOT,colorFF00FF;

A1AA:=9;

A2AA:=REF(CLOSE,A1AA+1)<CLOSE;

DRAWTEXT(FILTER(A2AA>-0.5,84),HIGH*1.05,'←---小心变盘'),colorFF00;

VAR6:=REF(CLOSE,1);

VAR7:=(SMA(MAX(CLOSE-VAR6,0),6,1))/(SMA(ABS(CLOSE-VAR6),6,1))*100;

DRAWTEXT(CROSS(82,VAR7),HIGH*1.02,'←---逃顶'),colorFFFF;

VAR3AA:=IF(CLOSE>REF(CLOSE,1),88,0);

VAR4AA:=IF(CLOSE/REF(CLOSE,1)>1.05 AND HIGH/CLOSE<1.01 AND VAR3AA>0,91,0);

DRAWTEXT(FILTER(VAR4AA>90,45),LOW*0.93,'←---大胆搏 '),colorFFFFFF;

V1:=MA(HIGH,30)*1.15;

V2:=MA(HIGH,3)*1.03;

V3:=MA(LOW,3)*0.97;

V4:=MA(LOW,30)*0.85;

L5:=ZIG(3,5);

EN1:=ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3);

EX1:=ZIG(3,5)<REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)>=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)>=REF(ZIG(3,5),3);

PL10:=ZIG(3,10);

EN2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)<=REF(ZIG(3,10),3);

EX2:=ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)>=REF(ZIG(3,10),3);

PL20:=ZIG(3,20);

EN3:=ZIG(3,20)>REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)<=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)<=REF(ZIG(3,20),3);

EX3:=ZIG(3,20)<REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)>=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)>=REF(ZIG(3,20),3);

PL40:=ZIG(3,40);

走强2:=BARSLAST(PL10<REF(PL10,1));

走弱2:=BARSLAST(PL10>REF(PL10,1));

走强3:=BARSLAST(PL20<REF(PL20,1));

走弱3:=BARSLAST(PL20>REF(PL20,1));

ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走强2),0);

ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,走强2),0);

DTJZ5:=IF(PL10<REF(PL10,1),COUNT(EN1,走弱2),0);

DTJD5:=IF(PL10<REF(PL10,1),COUNT(EX1,走弱2),0);

ZTJZ10:=IF(PL20>REF(PL20,1),COUNT(EN2,走强3),0);

ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,走强3),0);

DTJZ10:=IF(PL20<REF(PL20,1),COUNT(EN2,走弱3),0);

DTJD10:=IF(PL20<REF(PL20,1),COUNT(EX2,走弱3),0);

DRAWTEXT(EN1 AND DTJZ5=1,LOW*0.96,'㈠'),color1;

DRAWTEXT(EX1 AND DTJD5=2,HIGH*1.04,'㈡'),color1;

DRAWTEXT(EN2 AND ZTJZ5=1,LOW*0.96,'㈢'),color1;

DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJD5=1,HIGH*1,'⑴'),colorFFFF;

DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2,LOW*0.98,'⑵'),colorFFFF;

DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJZ5=2,HIGH*1,'⑶'),colorFFFF;

DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=3,LOW*0.98,'⑷'),colorFFFF;

DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,HIGH*1,'⑸'),colorFFFF;

DRAWTEXT(EN2 AND DTJZ10=1,LOW*0.9,'Ⅰ'),colorFF;

DRAWTEXT(EX2 AND DTJD10=2,HIGH*1.08,'Ⅱ'),colorFF;

DRAWTEXT(EN3 AND ZTJZ10=1,LOW*0.9,'Ⅲ'),colorFF;

DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,HIGH*1.02,'①'),colorFF00;

DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2,LOW*0.92,'②'),colorFF00;

DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=2 OR (ZTJD10=0 OR ZTJD10=2) AND EX2,HIGH*1.02,'③'),colorFF00;

DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=3,LOW*0.92,'④'),colorFF00;

E:=(HIGH+LOW+OPEN+2*CLOSE)/5;

ZL:=2*E-LOW;

ZC:=2*E-HIGH;

FZ:=E-(HIGH-LOW);

MA5:MA(CLOSE,5),LINETHICK0,colorF4E202;

MA6:=MA(CLOSE,6);

MA18:=MA(CLOSE,18);

MA13:MA(CLOSE,13),LINETHICK0,colorFF;

BALANCE:=EMA(CLOSE,30);

UP:=BALANCE+2*STD(CLOSE,30);

DOWN:=BALANCE-2*STD(CLOSE,30);

VAR9Q:=CLOSE=HHV(CLOSE,4) AND (REF(CLOSE,1)>=REF(CLOSE,2) OR REF(CLOSE,1)>=REF(CLOSE,3)) OR REF(CLOSE,1)=HHV(CLOSE,4) AND CLOSE>=REF(CLOSE,2) OR REF(CLOSE,2)=HHV(CLOSE,4) AND REF(CLOSE,3)=LLV(CLOSE,4) AND CLOSE>=REF(CLOSE,1) OR REF(CLOSE,3)=HHV(CLOSE,4) AND CLOSE>=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VARAQ:=CLOSE=HHV(CLOSE,4) AND REF(CLOSE,1)=LLV(CLOSE,4);

VARBQ:=CLOSE=LLV(CLOSE,4) AND (REF(CLOSE,1)<REF(CLOSE,2) OR REF(CLOSE,1)<REF(CLOSE,3)) OR REF(CLOSE,1)=LLV(CLOSE,4) AND CLOSE<REF(CLOSE,2) OR REF(CLOSE,2)=LLV(CLOSE,4) AND REF(CLOSE,1)<>HHV(CLOSE,4) AND CLOSE<REF(CLOSE,1) OR REF(CLOSE,3)=LLV(CLOSE,4) AND CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);

VARCQ:=REF(CLOSE,1)=LLV(CLOSE,4) AND CLOSE>=REF(CLOSE,2) OR REF(CLOSE,2)=LLV(CLOSE,4) AND REF(CLOSE,1)<=REF(CLOSE,3) AND REF(CLOSE,2)<REF(CLOSE,4) AND CLOSE>=REF(CLOSE,1);

VARDQ:=REF(CLOSE,1)=HHV(CLOSE,4) AND CLOSE<REF(CLOSE,2) OR (REF(CLOSE,2)=HHV(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,3) OR REF(CLOSE,3)=HHV(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,2)) AND REF(CLOSE,2)>=REF(CLOSE,4) AND CLOSE<REF(CLOSE,1);

Y1:=REF(EMA(DMA((HIGH+LOW+CLOSE*2)/4.15,0.9),3),1);

VAR1W:=100-90*(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21));

VAR2W:=100-90*(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21));

VAR3W:=100-MA(100*(HHV(HIGH,6)-CLOSE)/(HHV(HIGH,6)-LLV(LOW,6)),34);

VAR3P:=IF(CLOSE/REF(CLOSE,1)>1.05 AND HIGH/CLOSE<1.01 AND IF(CLOSE>REF(CLOSE,1),88,0)>0,91,0);

SS:=MA((LOW+HIGH+CLOSE)/3,5)>REF(MA((LOW+HIGH+CLOSE)/3,5),1) AND REF(MA((LOW+HIGH+CLOSE)/3,5),1)<REF(MA((LOW+HIGH+CLOSE)/3,5),2);

SC:=LOW<HHV(MA((LOW+HIGH+CLOSE)/3,5),13) AND HIGH>HHV(MA((LOW+HIGH+CLOSE)/3,5),13) AND CLOSE>REF(CLOSE,1) AND CLOSE>OPEN;

MR:=SC AND COUNT(SS,2);

买:=MR AND NOT(REF(MR,1));

多方:=7*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)-3*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1)-SMA(SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1),2,1);

VAR1:=(CLOSE-LLV(LOW,24))/(HHV(HIGH,24)-LLV(LOW,24))*1;

VAR2:=SMA(VAR1,3,1)*100;

趋势线:=SMA(SMA(VAR2,3,1)*VAR1,3,1)*1;

VAR9:=CROSS(趋势线,SMA(VAR2,3,1)*VAR1) AND SMA(VAR2,3,1)*VAR1>8;

AAX:=AMOUNT/VOL;

BBX:=LOW<AAX*0.9;

CCX:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>1.2;

DDX:=LOW<MA(CLOSE,5)*0.921;

EEX:=VOL<MA(VOL,5)*1.5;

FFX:=BBX AND CCX AND DDX AND EEX;

A:=(3*CLOSE+LOW+OPEN+HIGH)/6;

X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+REF(A,20))/210;

MTM:=CLOSE-REF(CLOSE,1);

DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);

CB:=EMA(X,13);

STICKLINE(CLOSE>BALANCE,BALANCE,BALANCE,1,0),LINETHICK2,colorFF;

STICKLINE(BALANCE>CLOSE,BALANCE,BALANCE,1,0),LINETHICK2,colorFF6600;

STICKLINE(CLOSE>OPEN,OPEN,LOW,0.5,0),colorFF;

STICKLINE(CLOSE>OPEN,CLOSE,HIGH,0.5,0),colorFF;

STICKLINE(OPEN>=CLOSE,CLOSE,LOW,0.5,0),colorFF00;

STICKLINE(OPEN>=CLOSE,OPEN,HIGH,0.5,0),colorFF00;

STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,7,0),colorFF7700;

STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,6,0),colorFF9900;

STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,5,0),colorFFBB00;

STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,4,0),colorFFCC00;

STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,3,0),colorFFDD00;

STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,2,0),colorFFEE00;

STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,1,0),colorFFFF00;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,7,0),color55;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6,0),color66;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,5,0),color77;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0),color99;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0),colorBB;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0),colorDD;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0),colorFF;

红:=VAR9Q;

STICKLINE(VAR9Q,CLOSE,(OPEN+CLOSE)/2,7,0),color55;

STICKLINE(VAR9Q,CLOSE,(OPEN+CLOSE)/2,6,0),color66;

STICKLINE(VAR9Q,CLOSE,(OPEN+CLOSE)/2,5,0),color77;

STICKLINE(VAR9Q,CLOSE,(OPEN+CLOSE)/2,4,0),color99;

STICKLINE(VAR9Q,CLOSE,(OPEN+CLOSE)/2,3,0),colorBB;

STICKLINE(VAR9Q,CLOSE,(OPEN+CLOSE)/2,2,0),colorDD;

STICKLINE(VAR9Q,CLOSE,(OPEN+CLOSE)/2,1,0),colorFF;

粉:=VARAQ;

STICKLINE(VARAQ,CLOSE,(OPEN+CLOSE)/2,7,0),colorFF11FF;

STICKLINE(VARAQ,CLOSE,(OPEN+CLOSE)/2,6,0),colorFF33FF;

STICKLINE(VARAQ,CLOSE,(OPEN+CLOSE)/2,5,0),colorFF55FF;

STICKLINE(VARAQ,CLOSE,(OPEN+CLOSE)/2,4,0),colorFF77FF;

STICKLINE(VARAQ,CLOSE,(OPEN+CLOSE)/2,3,0),colorFF99FF;

STICKLINE(VARAQ,CLOSE,(OPEN+CLOSE)/2,2,0),colorFFBBFF;

STICKLINE(VARAQ,CLOSE,(OPEN+CLOSE)/2,1,0),colorFFDDFF;

灰:=VARBQ;

STICKLINE(VARBQ,CLOSE,(OPEN+CLOSE)/2,7,0),color333333;

STICKLINE(VARBQ,CLOSE,(OPEN+CLOSE)/2,6,0),color555555;

STICKLINE(VARBQ,CLOSE,(OPEN+CLOSE)/2,5,0),color777777;

STICKLINE(VARBQ,CLOSE,(OPEN+CLOSE)/2,4,0),color999999;

STICKLINE(VARBQ,CLOSE,(OPEN+CLOSE)/2,3,0),colorBBBBBB;

STICKLINE(VARBQ,CLOSE,(OPEN+CLOSE)/2,2,0),colorDDDDDD;

STICKLINE(VARBQ,CLOSE,(OPEN+CLOSE)/2,1,0),colorFFFFFF;

绿:=VARCQ;

STICKLINE(VARCQ,OPEN,(OPEN+CLOSE)/2,7,0),color3300;

STICKLINE(VARCQ,OPEN,(OPEN+CLOSE)/2,6,0),color5500;

STICKLINE(VARCQ,OPEN,(OPEN+CLOSE)/2,5,0),color7700;

STICKLINE(VARCQ,OPEN,(OPEN+CLOSE)/2,4,0),color9900;

STICKLINE(VARCQ,OPEN,(OPEN+CLOSE)/2,3,0),colorBB00;

STICKLINE(VARCQ,OPEN,(OPEN+CLOSE)/2,2,0),colorDD00;

STICKLINE(VARCQ,OPEN,(OPEN+CLOSE)/2,1,0),colorFF00;

蓝:=VARDQ;

STICKLINE(VARDQ,OPEN,(OPEN+CLOSE)/2,7,0),colorFF1100;

STICKLINE(VARDQ,OPEN,(OPEN+CLOSE)/2,6,0),colorFF3300;

STICKLINE(VARDQ,OPEN,(OPEN+CLOSE)/2,5,0),colorFF5500;

STICKLINE(VARDQ,OPEN,(OPEN+CLOSE)/2,4,0),colorFF7700;

STICKLINE(VARDQ,OPEN,(OPEN+CLOSE)/2,3,0),colorFF9900;

STICKLINE(VARDQ,OPEN,(OPEN+CLOSE)/2,2,0),colorFFBB00;

STICKLINE(VARDQ,OPEN,(OPEN+CLOSE)/2,1,0),colorFFDD00;

卖:=IF(HHV(DX,2)=HHV(DX,7) AND COUNT(DX>50,2) AND CROSS(MA(DX,2),DX),1,0);

DRAWTEXT(FILTER(卖=1,1),HIGH*1.02,'卖'),colorFFFFFF;

买:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);

DRAWTEXT(FILTER(买=1,5),LOW-0.03,'买'),colorFF;

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:=SMA(RSV,3,1);

D:=SMA(K,3,1);

J:=3*K-2*D;

BDGD:=HHV(J,2)=HHV(J,8) AND J>80;

注意:=IF(CROSS(REF(J-0.01,1),J) AND REF(BDGD,1),1,0);

DRAWTEXT(注意 AND 卖<>1,HIGH*1.02,'减'),colorFFFF50;

加仓A:=SMA(EMA((CLOSE-REF(CLOSE,1))/REF(CLOSE,1),5)*100,3,1)*10;

DRAWTEXT(FILTER((CROSS(加仓A,0) OR CROSS(CLOSE,CB)) AND 买<>1,3),LOW-0.03,'加'),color80FF;

跟:=IF(MA18>=REF(MA18,3) AND CROSS(CLOSE,MA18),1,0);

DRAWTEXT(MA18>=REF(MA18,3) AND CROSS(CLOSE,MA18),LOW*0.96,'跟'),color7F52AF;

DRAWTEXTEX(CLOSE,0,10,15,'上升阻力:'+NUMTOSTR(ZL,2)),colorFF;

DRAWTEXTEX(CLOSE,0,10,35,'下跌支撑:'+NUMTOSTR(ZC,2)),colorFF00;

DRAWTEXTEX(CLOSE,0,10,55,'下跌反转:'+NUMTOSTR(FZ,2)),colorFFFFFF;

非分笔图:=IF(TIME0=0,1,0);

SAT:=IF(AMOUNT/CLOSE/(HHV(AMOUNT,20)/HHV(CLOSE,20))*100>100,100,AMOUNT/CLOSE/(HHV(AMOUNT,20)/HHV(CLOSE,20))*100);

量能饱和度:SAT,LINETHICK0;

VAR7:=EMA(AMOUNT/VOL/100,3);

VAR8:=EMA(VAR7,88);

VAR9:=EMA(VAR7,88)*0.85;

VARA:=VAR9*0.87;

VARB:=LOW<VARA AND CLOSE>REF(CLOSE,1)*1.02;

DRAWTEXT(FILTER(VARB,6),LOW,'★'),colorFF00FF;

VARF:=(2*CLOSE+HIGH+LOW)/4;

VA4:=LLV(LOW,34);

VA5:=HHV(HIGH,34);

VA6:=EMA((VARF-VA4)/(VA5-VA4)*100,6);

VA7:=EMA(0.667*REF(VA6,1)+0.333*VA6,4);

DRAWTEXT(IF((COUNT(CLOSE<REF(CLOSE,1),8))/8>0.3 AND COUNT(VA6>VA7,3) AND REF(LOW,1)=LLV(LOW,120) AND CLOSE>OPEN,1,0),LOW,'★'),colorFFFF;

DRAWTEXT(IF((COUNT(CLOSE<REF(CLOSE,1),8))/8>0.3 AND COUNT(VA6>VA7,3) AND REF(LOW,1)=LLV(LOW,120) AND CLOSE>OPEN,1,0),LOW-0.14,'出击'),colorFFFF;

A:=(3*CLOSE+LOW+OPEN+HIGH)/6;

D1:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+REF(A,20))/211;

D2:=EMA(D1,2);

D3:=EMA(D2,2);

K1:=EMA(D3,2);

DRAWTEXT(CROSS(D1,K1),LOW-0.14,'波买'),color99FF;

DRAWTEXT(CROSS(D1,K1),LOW,'★'),color99FF;

QH:=REF(HIGH,2);

QL:=REF(LOW,2);

QO:=REF(OPEN,2);

QC:=REF(CLOSE,2);

ZO:=REF(OPEN,1);

ZC:=REF(CLOSE,1);

MA30:MA(CLOSE,30),LINETHICK0,color99FF;

JYZHK:=(ABS(QO-QC))/QO<0.02 AND ZO/ZC>1.02 AND (ABS(OPEN-CLOSE))/OPEN<0.02 AND CLOSE>MA30;

JYZHV:=VOL<REF(VOL,1);

JYZH:=JYZHK AND JYZHV;

DRAWTEXT(JYZH,LOW,'金印');

现价:CLOSE,POINTDOT,LINETHICK0,colorFFFFFF;

现量:VOL,LINETHICK0,colorFF00;

VAR1:=BACKSET(REF(HIGH,2)=HHV(HIGH,5),3);

VAR2:=CROSS(VAR1,0.9);

VAR3:=BACKSET(REF(LOW,2)=LLV(LOW,5),3);

VAR4:=CROSS(VAR3,0.9);

STICKLINE(VAR2,HIGH,HIGH*1.01,5,0),colorE40E;

STICKLINE(VAR4,LOW,LOW*0.99,5,0),colorE40E;

VAR5:=IF(VAR2,HIGH,IF(VAR4,LOW,0));

VAR6:=BACKSET(REF(HIGH,2)=HHV(HIGH,5) AND LOW<REF(LOW,1) AND HIGH<REF(HIGH,1),3);

VAR7:=BACKSET(REF(HIGH,2)=HHV(HIGH,5) AND LOW>REF(LOW,1) AND HIGH>REF(HIGH,1),3);

VAR8:=BACKSET(REF(HIGH,2)=HHV(HIGH,5) AND HIGH<REF(HIGH,1) AND LOW>REF(LOW,1) AND REF(LOW,1)>REF(LOW,2) AND REF(HIGH,1)<REF(HIGH,2),3);

VAR9:=BACKSET(REF(LOW,2)=LLV(LOW,5) AND LOW>REF(LOW,1) AND HIGH>REF(HIGH,1),3);

VARA:=BACKSET(REF(LOW,2)=LLV(LOW,5) AND LOW<REF(LOW,1) AND HIGH<REF(HIGH,1),3);

VARB:=BACKSET(REF(LOW,2)=LLV(LOW,5) AND HIGH<REF(HIGH,1) AND LOW>REF(LOW,1) AND REF(LOW,1)>REF(LOW,2) AND REF(HIGH,1)<REF(HIGH,2),3);

坚定:STICKLINE(CROSS(VAR6,0.9),HIGH,HIGH*1.01,5,0),LINETHICK0,colorFF;

STICKLINE(CROSS(VAR9,0.9),LOW,LOW*0.99,5,0),LINETHICK0,colorFF;

犹豫:STICKLINE(CROSS(VAR7,0.9),HIGH,HIGH*1.01,5,0),colorE5E9;

STICKLINE(CROSS(VARA,0.9),LOW,LOW*0.99,5,0),LINETHICK0,colorE5E9;

等待:STICKLINE(CROSS(VAR8,0.9),HIGH,HIGH*1.01,5,0),colorFF4100;

STICKLINE(CROSS(VARB,0.9),LOW,LOW*0.99,5,0),LINETHICK0,colorFF4100;

压力:REF(HIGH,BARSLAST(VAR2)),POINTDOT,colorEA91B5;

STICKLINE(CLOSE,REF(HIGH,BARSLAST(VAR2)),REF(HIGH,BARSLAST(VAR2)),5,0),LINETHICK0,colorFF00;

支撑:REF(LOW,BARSLAST(VAR4)),POINTDOT,color3791B5;//强龙网https://qianglong.wang

STICKLINE(CLOSE,REF(LOW,BARSLAST(VAR4)),REF(LOW,BARSLAST(VAR4)),5,0),LINETHICK0,colorFFFF;

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: