降魔妖(通达信公式 和谐源码分享 K线图)

  • A+
所属分类:通达信公式

指标代码及说明:

{公式名称: 降魔妖}

VAR1:=MA(CLOSE,5);

VAR2:=MA(CLOSE,10);

VAR3:=IF(CLOSE>=SAR.SAR AND (CLOSE>VAR1 OR CLOSE>VAR2),70,0);

VAR4:=IF(CLOSE>SAR.SAR AND (CLOSE<VAR1 AND CLOSE<VAR2),50,0);

VAR5:=IF(CLOSE<SAR.SAR,30,0);

VAR6:=VAR3+VAR4+VAR5;

VAR7:=IF(CLOSE>VAR1 AND VAR1>VAR2,70,0);

VAR8:=IF(CLOSE<VAR1 AND VAR1<VAR2,30,0);

VAR9:=VAR7+VAR8;

VAR10:=IF(VAR9=0,50,0);

VAR11:=VAR7+VAR8+VAR10;

VAR12:=VAR6*0.5+VAR11*0.5;

VAR13:=10;

VAR14:=NOT(NAMELIKE(1) OR NAMELIKE(2));

VAR15:=(CLOSE>=ZTPRICE(REF(CLOSE,1),0.1) AND LOW<HIGH)*8;

VAR16:=BARSCOUNT(CLOSE)>=30;

VAR17:=(CLOSE>=ZTPRICE(REF(CLOSE,1),0.1) AND LOW=HIGH)*3;

VAR18:=CLOSE>OPEN*1.027;

VAR19:=(HIGH>=ZTPRICE(REF(CLOSE,1),0.1) AND CLOSE<HIGH)*2;

VAR20:=VAR13+VAR15+VAR17+VAR19;

VAR21:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;

VAR22:=VAR20*VAR21;

VAR23:=(EMA(CLOSE,12)/EMA(CLOSE,26)-1)*1000;

VAR24:=DYNAINFO(4)>0;

VAR25:=EMA(VAR23,5);

VAR26:=VAR25-REF(VAR25,1);

VAR27:=(EMA(INDEXC,12)/EMA(INDEXC,26)-1)*1000;

VAR28:=EMA(VAR27,5);

VAR29:=VAR28-REF(VAR28,1);

VAR30:=(VAR26-VAR29)*50;

VAR31:=VAR22+VAR30+VAR12;

VAR32:=VAR31>470;

VAR33:=BARSLAST(VAR32);

VAR34:=1171230;

VAR35:=DATE<VAR34;

VAR36:=BETWEEN(VAR33,0,2);

VAR37:=MA(CLOSE,5);

VAR38:=MA(CLOSE,10);

VAR39:=VAR38<VAR37;

VAR40:=REF(VAR36,1)>0 AND VAR39;

VAR41:=REF(VAR40,1) AND VAR14 AND VAR16 AND VAR18 AND VAR24;

XG:FILTER(VAR41,20);

{降魔妖}

{选股}

VAR1:=MA(CLOSE,5);

VAR2:=MA(CLOSE,10);

VAR3:=IF(CLOSE>=SAR.SAR AND (CLOSE>VAR1 OR CLOSE>VAR2),70,0);

VAR4:=IF(CLOSE>SAR.SAR AND (CLOSE<VAR1 AND CLOSE<VAR2),50,0);

VAR5:=IF(CLOSE<SAR.SAR,30,0);

VAR6:=VAR3+VAR4+VAR5;

VAR7:=IF(CLOSE>VAR1 AND VAR1>VAR2,70,0);

VAR8:=IF(CLOSE<VAR1 AND VAR1<VAR2,30,0);

VAR9:=VAR7+VAR8;

VAR10:=IF(VAR9=0,50,0);

VAR11:=VAR7+VAR8+VAR10;

VAR12:=VAR6*0.5+VAR11*0.5;

VAR13:=10;

VAR14:=NOT(NAMELIKE(1) OR NAMELIKE(2));

VAR15:=(CLOSE>=ZTPRICE(REF(CLOSE,1),0.1) AND LOW<HIGH)*8;

VAR16:=BARSCOUNT(CLOSE)>=30;

VAR17:=(CLOSE>=ZTPRICE(REF(CLOSE,1),0.1) AND LOW=HIGH)*3;

VAR18:=CLOSE>OPEN*1.027;

VAR19:=(HIGH>=ZTPRICE(REF(CLOSE,1),0.1) AND CLOSE<HIGH)*2;

VAR20:=VAR13+VAR15+VAR17+VAR19;

VAR21:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;

VAR22:=VAR20*VAR21;

VAR23:=(EMA(CLOSE,12)/EMA(CLOSE,26)-1)*1000;

VAR24:=DYNAINFO(4)>0;

VAR25:=EMA(VAR23,5);

VAR26:=VAR25-REF(VAR25,1);

VAR27:=(EMA(INDEXC,12)/EMA(INDEXC,26)-1)*1000;

VAR28:=EMA(VAR27,5);

VAR29:=VAR28-REF(VAR28,1);

VAR30:=(VAR26-VAR29)*50;

VAR31:=VAR22+VAR30+VAR12;

VAR32:=VAR31>470;

VAR33:=BARSLAST(VAR32);

VAR36:=BETWEEN(VAR33,0,2);

VAR37:=MA(CLOSE,5);

VAR38:=MA(CLOSE,10);

VAR39:=VAR38<VAR37;

VAR40:=REF(VAR36,1)>0 AND VAR39;

VAR41:=REF(VAR40,1) AND VAR14 AND VAR16 AND VAR18 AND VAR24;

XG:FILTER(VAR41,20);

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: