多空潜伏精品副图+选股指标 通达信 贴图 优化系统指标 自编选股

  • A+
所属分类:通达信公式

指标代码及说明:

							

指标用法:

1.多空信号:老规矩,红色为多信号,绿色为空信号,结合均线和量能、macd来看更好。

2.逼空无线区和牛多无线区:所谓逼空无线区,就是黄线和紫线绿线大角度上穿20线,同时白线大角度向下下穿20线,在多空双方在20线上下长期形成一个无线区,此区间不宜参与,经常伴随下跌,有多信号也是诱多;所谓牛多无线区,就是白线和紫线绿线大角度上穿20线,同时黄线大角度向下下穿20线,在多空双方在20线上下长期形成一个无线区,此区间为涨势区,经常伴随大涨,有空信号也是诱空。

3.潜伏信号:潜伏信号我做成了一个选股公式,但不是所有信号都能成功,世界上没有一劳永逸的指标,也没有一成不变操盘的庄家主力,所以不要指望所有信号都管用,但选股选出数量已经相当少了,一般不超过20个。大家可以运用指标副图对照看过去的票,仿照副图说明,形成自己的选股模型:比如横盘+短期最低价+黄金坑+潜伏信号=暴涨......,这个需要自己反复去总结,相信各人有个人的妙用。

4.强势启动选股:用多个多信号做成了一个强势拉升启动的选股公式,选出来才发现,都是涨停或有大阳线的,这个要防止回调,毕竟物极必反,但是后期中长线还是看多,这个要各人结合盘感来看。

5.总的原则:物极必反,长期走空的股票,空方力量得到释放,这个时候,指标看多的提示信号更为有效,相反也是如此,长期走多,甚至暴涨的股票,出现空信号就要重视,绝不贸然追涨,避免被套。

DRAWTEXT_FIX(ISLASTBAR,0,0,0,'胤夫出品,必属精品'),COLORRED;

{趋向指标}

{N 2 90 14 M 2 60 6}

MTR:=SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);

HD :=HIGH-REF(HIGH,1);

LD :=REF(LOW,1)-LOW;

DMP:=SUM(IF(HD>0&&HD>LD,HD,0),N);

DMM:=SUM(IF(LD>0&&LD>HD,LD,0),N);

PDI: DMP*100/MTR;

MDI: DMM*100/MTR;

ADX: MA(ABS(MDI-PDI)/(MDI+PDI)*100,M);

ADXR:(ADX+REF(ADX,M))/2;

看多线:20,DOTLINE,COLORRED;

MA5:=MA(C,5);MA10:=MA(C,10);MA20:=MA(C,20);MA30:=MA(C,30);MA60:=MA(C,60);

MAX1:=MAX(MA5,MA10);

MAX2:=MAX(MAX1,MA20);

MAX3:=MAX(MAX2,MA30);

MAXH:=MAX(MAX3,MA60);

MIN1B:=MIN(MA5,MA10);

MIN2:=MIN(MIN1B,MA20);

MIN3:=MIN(MIN2,MA30);

MINL:=MIN(MIN3,MA60);

粘合度:=(MAXH-MINL)/MINL*100;

多头发散:=MA5>REF(MA5,1) AND MA5>MA10 AND MA10>=REF(MA10,1) AND MA10>MA20 AND MA20>=REF(MA20,1) AND MA20>MA30 AND MA30>=REF(MA30,1) AND MA30>MA60 AND MA60>=REF(MA60,1);

选股:BARSLASTCOUNT(粘合度<=5)=2 AND 多头发散;

DRAWTEXT(CROSS(PDI,MDI) AND EXIST(粘合度<=8,5) AND MA(C,20)-REF(MA(C,20),1)>REF(MA(C,20),1)-REF(MA(C,20),2)

AND MA(C,5)>REF(MA(C,5),1) AND MA(C,10)>REF(MA(C,10),1),38,'多'),COLORRED;

DRAWTEXT(CROSS(PDI,MDI) AND EXIST(粘合度<=8,5) AND MA(C,20)-REF(MA(C,20),1)>REF(MA(C,20),1)-REF(MA(C,20),2)

AND MA(C,5)>REF(MA(C,5),1) AND MA(C,10)>REF(MA(C,10),1),48,'看'),COLORRED;

DRAWTEXT(CROSS(MDI,PDI),38,'看'),COLORGREEN;

DRAWTEXT(CROSS(MDI,PDI),26,'空'),COLORGREEN;

DRAWTEXT(CROSS(PDI,MDI) AND ADX>20 AND ADXR>20 AND MA(C,10)>REF(MA(C,10),1)

,28,'主'),COLORRED;

DRAWTEXT(CROSS(PDI,MDI) AND ADX>20 AND ADXR>20 AND MA(C,10)>REF(MA(C,10),1)

,18,'升'),COLORRED;

DRAWTEXT(CROSS(PDI,ADX) AND CROSS(PDI,ADXR) AND MDI<REF(MDI,1) AND ADX>REF(ADX,1) AND ADXR>REF(ADXR,1)

AND ATAN((PDI/REF(PDI,1)-1)*100)*180/3.1416>60 AND

ATAN(((2*REF(MDI,1)-MDI)/REF(MDI,1)-1)*100)*180/3.1416>45,58,'走'),COLORRED;

DRAWTEXT(CROSS(PDI,ADX) AND CROSS(PDI,ADXR) AND MDI<REF(MDI,1) AND ADX>REF(ADX,1) AND ADXR>REF(ADXR,1)

AND ATAN((PDI/REF(PDI,1)-1)*100)*180/3.1416>60 AND

ATAN(((2*REF(MDI,1)-MDI)/REF(MDI,1)-1)*100)*180/3.1416>45,48,'牛'),COLORRED;

升1:=CROSS(ADXR,20) AND ATAN((ADXR/REF(ADXR,1)-1)*100)*180/3.1416>60;

升2:=CROSS(ADX,20) AND ATAN((ADX/REF(ADX,1)-1)*100)*180/3.1416>60;

升3:=CROSS(PDI,20) AND ATAN((PDI/REF(PDI,1)-1)*100)*180/3.1416>60;

升4:=CROSS(20,MDI) AND ATAN(((2*REF(MDI,1)-MDI)/REF(MDI,1)-1)*100)*180/3.1416>45;

反降:=MDI<REF(MDI,1) AND ATAN(((2*REF(MDI,1)-MDI)/REF(MDI,1)-1)*100)*180/3.1416>45;

升:=升1 OR 升2 OR 升3 OR 升4;{好股票WWW.GOODGUPIAO.COM}

DRAWTEXT(升 AND 反降 AND ADX>20 AND ADXR>20 AND PDI>20 AND ADX>REF(ADX,1) AND PDI>=REF(PDI,1) AND MA(C,5)>REF(MA(C,5),1),46,'升'),COLORRED;

DRAWTEXT(升 AND 反降 AND ADX>20 AND ADXR>20 AND PDI>20 AND ADX>REF(ADX,1) AND PDI>=REF(PDI,1) AND MA(C,5)>REF(MA(C,5),1),36,'势'),COLORRED;

DRAWTEXT(ADX<REF(ADX,1) AND ADXR<REF(ADXR,1) AND PDI<REF(PDI,1) AND MDI>REF(MDI,1)

AND MA(C,5)<REF(MA(C,5),1),44,'降'),COLORGREEN;

DRAWICON(CROSS(PDI,MDI),PDI,1);

DRAWICON(CROSS(MDI,PDI),MDI,2);

DRAWTEXT(CROSS(PDI,ADXR) AND ATAN((PDI/REF(PDI,1)-1)*100)*180/3.1416>60 AND MDI<=REF(MDI,1) AND MA(C,5)>REF(MA(C,5),1) AND PDI>MDI,22,'短'),COLORRED;

DRAWTEXT(CROSS(PDI,ADXR) AND ATAN((PDI/REF(PDI,1)-1)*100)*180/3.1416>60 AND MDI<=REF(MDI,1) AND MA(C,5)>REF(MA(C,5),1) AND PDI>MDI,18,'升'),COLORRED;

{黄金坑}

RR1:=MA(CLOSE,27);

RR2:=(CLOSE-RR1)/RR1*100;

RRA:=MA(RR2,2);

RRB:=BARSLAST(CROSS(-10,RRA)=1);

RRD:=RRA<-10 AND RRB>3;

黄金坑:=IF(RRD,-120,0);

{CCI}

TYP:=(HIGH+LOW+CLOSE)/3;

CCI:=(TYP-MA(TYP,NC))/(0.015*AVEDEV(TYP,NC));

DRAWTEXT(CROSS(CCI,0),66,'上'),COLORRED;

DRAWTEXT(CROSS(0,CCI),66,'下'),COLORGREEN;

DRAWTEXT(CROSS(CCI,100),56,'突'),COLORRED;

DRAWTEXT(CROSS(100,CCI),56,'落'),COLORGREEN;

DRAWTEXT(CROSS(100,CCI) AND MA(C,20)>REF(MA(C,20),1),60,'暂'),COLORGREEN;

叉1:=CROSS(ADX,0) AND ATAN((ADX/REF(ADX,1)-1)*100)*180/3.1416>60;

叉2:=CROSS(ADXR,0) AND ATAN((ADXR/REF(ADXR,1)-1)*100)*180/3.1416>60;

叉3:=CROSS(20,PDI) AND ATAN(((2*REF(PDI,1)-PDI)/REF(PDI,1)-1)*100)*180/3.1416>45;

叉4:=CROSS(MDI,20) AND ATAN((MDI/REF(MDI,1)-1)*100)*180/3.1416>45;

叉:=叉1 OR 叉2 OR 叉3 OR 叉4;

逆势:=MDI>REF(MDI,1) AND ATAN((MDI/REF(MDI,1)-1)*100)*180/3.1416>45 AND MDI>20;

DRAWTEXT(叉 AND 逆势 AND PDI<20 AND MDI>20 AND ADX>20 AND ADXR>20,54,'跌'),COLORGREEN;

DRAWTEXT(叉 AND 逆势 AND PDI<20 AND MDI>20 AND ADX>20 AND ADXR>20,50,'势'),COLORGREEN;

跌角1:=ATAN((ADXR/REF(ADXR,1)-1)*100)*180/3.1416>60 AND ATAN((ADXR/REF(ADXR,1)-1)*100)*180/3.1416>60

AND ATAN((MDI/REF(MDI,1)-1)*100)*180/3.1416>60 AND ADXR>20 AND ADX>20 AND MDI>20 AND MDI>REF(MDI,1);

DRAWTEXT(跌角1 AND ATAN(((2*REF(PDI,1)-PDI)/REF(PDI,1)-1)*100)*180/3.1416>45 AND MA(C,10)<REF(MA(C,10),1),34,'大'),COLORGREEN;

DRAWTEXT(跌角1 AND ATAN(((2*REF(PDI,1)-PDI)/REF(PDI,1)-1)*100)*180/3.1416>45 AND MA(C,10)<REF(MA(C,10),1),30,'跌'),COLORGREEN;

潜伏:=CROSS(PDI,MDI) AND MA(C,5)>REF(MA(C,5),1) AND MA(C,10)>REF(MA(C,10),1) AND

MA(C,20)-REF(MA(C,20),1)>REF(MA(C,20),1)-REF(MA(C,20),2) AND EXIST(粘合度<=8,5);

潜伏2:=CROSS(PDI,MDI) AND MA(C,5)>REF(MA(C,5),1) AND MA(C,10)>REF(MA(C,10),1) AND

MA(C,20)-REF(MA(C,20),1)>REF(MA(C,20),1)-REF(MA(C,20),2) AND EXIST(粘合度<=8,5) AND EXIST(黄金坑,10);

DRAWTEXT(潜伏,14,'潜'),COLORYELLOW;

DRAWTEXT(潜伏,10,'伏'),COLORYELLOW;

DRAWTEXT(潜伏2,6,'潜'),COLORRED;

DRAWTEXT(潜伏2,2,'伏'),COLORRED;

指标效果图:

多空潜伏精品副图+选股指标 通达信 贴图 优化系统指标 自编选股

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: