文华财经公式集(源码)开放.doc

  • A+
所属分类:文华公式

指标代码及说明:

文华财经公式判断趋势MA50:MA(CLOSE,50);STICKLINE(CLOSE<MA50,OPEN,CLOSE,COLORCYAN,0);DRAWLINE(CLOSE<MA50,HIGH,CLOSE<MA50,LOW,COLORCYAN);STICKLINE(CLOSE>MA50,OPEN,CLOSE,COLORRED,0);DRAWLINE(CLOSE>MA50,HIGH,CLOSE>MA50,LOW,COLORRED);每日均价A1:=IF(DAY=1,CLOSE,0);A2:=IF(DAY=2,CLOSE,0);A3:=IF(DAY=3,CLOSE,0);A4:=IF(DAY=4,CLOSE,0);A5:=IF(DAY=5,CLOSE,0);A6:=IF(DAY=6,CLOSE,0);A7:=IF(DAY=7,CLOSE,0);A8:=IF(DAY=8,CLOSE,0);A9:=IF(DAY=9,CLOSE,0);A10:=IF(DAY=10,CLOSE,0);A11:=IF(DAY=11,CLOSE,0);A12:=IF(DAY=12,CLOSE,0);A13:=IF(DAY=13,CLOSE,0);A14:=IF(DAY=14,CLOSE,0);A15:=IF(DAY=15,CLOSE,0);A16:=IF(DAY=16,CLOSE,0);A17:=IF(DAY=17,CLOSE,0);A18:=IF(DAY=18,CLOSE,0);A19:=IF(DAY=19,CLOSE,0);A20:=IF(DAY=20,CLOSE,0);A21:=IF(DAY=21,CLOSE,0);A22:=IF(DAY=22,CLOSE,0);A23:=IF(DAY=23,CLOSE,0);A24:=IF(DAY=24,CLOSE,0);A25:=IF(DAY=25,CLOSE,0);A26:=IF(DAY=26,CLOSE,0);A27:=IF(DAY=27,CLOSE,0);A28:=IF(DAY=28,CLOSE,0);A29:=IF(DAY=29,CLOSE,0);A30:=IF(DAY=30,CLOSE,0);A31:=IF(DAY=31,CLOSE,0);B1:=IF(DAY=1,VOL,0);B2:=IF(DAY=2,VOL,0);B3:=IF(DAY=3,VOL,0);B4:=IF(DAY=4,VOL,0);B5:=IF(DAY=5,VOL,0);B6:=IF(DAY=6,VOL,0);B7:=IF(DAY=7,VOL,0);B8:=IF(DAY=8,VOL,0);B9:=IF(DAY=9,VOL,0);B10:=IF(DAY=10,VOL,0);B11:=IF(DAY=11,VOL,0);B12:=IF(DAY=12,VOL,0);B13:=IF(DAY=13,VOL,0);B14:=IF(DAY=14,VOL,0);B15:=IF(DAY=15,VOL,0);B16:=IF(DAY=16,VOL,0);B17:=IF(DAY=17,VOL,0);B18:=IF(DAY=18,VOL,0);B19:=IF(DAY=19,VOL,0);B20:=IF(DAY=20,VOL,0);B21:=IF(DAY=21,VOL,0);B22:=IF(DAY=22,VOL,0);B23:=IF(DAY=23,VOL,0);B24:=IF(DAY=24,VOL,0);B25:=IF(DAY=25,VOL,0);B26:=IF(DAY=26,VOL,0);B27:=IF(DAY=27,VOL,0);B28:=IF(DAY=28,VOL,0);B29:=IF(DAY=29,VOL,0);B30:=IF(DAY=30,VOL,0);B31:=IF(DAY=31,VOL,0);AB1:=SUM(A1*B1,N)/SUM(B1,N);AB2:=SUM(A2*B2,N)/SUM(B2,N);AB3:=SUM(A3*B3,N)/SUM(B3,N);AB4:=SUM(A4*B4,N)/SUM(B4,N);AB5:=SUM(A5*B5,N)/SUM(B5,N);AB6:=SUM(A6*B6,N)/SUM(B6,N);AB7:=SUM(A7*B7,N)/SUM(B7,N);AB8:=SUM(A8*B8,N)/SUM(B8,N);AB9:=SUM(A9*B9,N)/SUM(B9,N);AB10:=SUM(A10*B10,N)/SUM(B10,N);AB11:=SUM(A11*B11,N)/SUM(B11,N);AB12:=SUM(A12*B12,N)/SUM(B12,N);AB13:=SUM(A13*B13,N)/SUM(B13,N);AB14:=SUM(A14*B14,N)/SUM(B14,N);AB15:=SUM(A15*B15,N)/SUM(B15,N);AB16:=SUM(A16*B16,N)/SUM(B16,N);AB17:=SUM(A17*B17,N)/SUM(B17,N);AB18:=SUM(A18*B18,N)/SUM(B18,N);AB19:=SUM(A19*B19,N)/SUM(B19,N);AB20:=SUM(A20*B20,N)/SUM(B20,N);AB21:=SUM(A21*B21,N)/SUM(B21,N);AB22:=SUM(A22*B22,N)/SUM(B22,N);AB23:=SUM(A23*B23,N)/SUM(B23,N);AB24:=SUM(A24*B24,N)/SUM(B24,N);AB25:=SUM(A25*B25,N)/SUM(B25,N);AB26:=SUM(A26*B26,N)/SUM(B26,N);AB27:=SUM(A27*B27,N)/SUM(B27,N);AB28:=SUM(A28*B28,N)/SUM(B28,N);AB29:=SUM(A29*B29,N)/SUM(B29,N);AB30:=SUM(A30*B30,N)/SUM(B30,N);AB31:=SUM(A31*B31,N)/SUM(B31,N);PARTLINE(DAY=1,AB1,COLORYELLOW);PARTLINE(DAY=2,AB2,COLORYELLOW);PARTLINE(DAY=3,AB3,COLORYELLOW);PARTLINE(DAY=4,AB4,COLORYELLOW);PARTLINE(DAY=5,AB5,COLORYELLOW);PARTLINE(DAY=6,AB6,COLORYELLOW);PARTLINE(DAY=7,AB7,COLORYELLOW);PARTLINE(DAY=8,AB8,COLORYELLOW);PARTLINE(DAY=9,AB9,COLORYELLOW);PARTLINE(DAY=10,AB10,COLORYELLOW);PARTLINE(DAY=11,AB11,COLORYELLOW);PARTLINE(DAY=12,AB12,COLORYELLOW);PARTLINE(DAY=13,AB13,COLORYELLOW);PARTLINE(DAY=14,AB14,COLORYELLOW);PARTLINE(DAY=15,AB15,COLORYELLOW);PARTLINE(DAY=16,AB16,COLORYELLOW);PARTLINE(DAY=17,AB17,COLORYELLOW);PARTLINE(DAY=18,AB18,COLORYELLOW);PARTLINE(DAY=19,AB19,COLORYELLOW);PARTLINE(DAY=20,AB20,COLORYELLOW);PARTLINE(DAY=21,AB21,COLORYELLOW);PARTLINE(DAY=22,AB22,COLORYELLOW);PARTLINE(DAY=23,AB23,COLORYELLOW);PARTLINE(DAY=24,AB24,COLORYELLOW);PARTLINE(DAY=25,AB25,COLORYELLOW);PARTLINE(DAY=26,AB26,COLORYELLOW);PARTLINE(DAY=27,AB27,COLORYELLOW);PARTLINE(DAY=28,AB28,COLORYELLOW);PARTLINE(DAY=29,AB29,COLORYELLOW);PARTLINE(DAY=30,AB30,COLORYELLOW);PARTLINE(DAY=31,AB31,COLORYELLOW);N=31买卖频谱X:=BARSLAST(HIGH=HHV(HIGH,N));LL:=MIN(REF(LOW,X+3),MIN(REF(LOW,X+2),MIN(REF(LOW,X),REF(LOW,X+1))));Y:=BARSLAST(LOW=LLV(LOW,N));HH:=MAX(REF(HIGH,Y+3),MAX(REF(HIGH,Y+2),MAX(REF(HIGH,Y),REF(HIGH,Y+1))));A:=BARSLAST(CLOSE>=HH);B:=BARSLAST(CLOSE<=LL);AB:IF(A>B,HH,LL);TM:=CLOSE>=AB;TP:=CLOSE<AB;DRAWLINE(TP,HIGH,TP,OPEN,COLORCYAN);DRAWLINE(TP,LOW,TP,CLOSE,COLORCYAN);DRAWLINE(TM,HIGH,TM,CLOSE,COLORRED);DRAWLINE(TM,LOW,TM,OPEN,COLORRED);STICKLINE(TP,OPEN,CLOSE,COLORCYAN,0);STICKLINE(TM,OPEN,CLOSE,COLORRED,1);HH1:=BARSLAST((HH > REF(HH,1)));LL1:=BARSLAST((LL < REF(LL,1)));N=10龙出沧海公式!!!VAR2:=(3*CLOSE+LOW+OPEN+HIGH)/6; DTX:(20*VAR2+19*REF(VAR2,1)+18*REF(VAR2,2)+17*REF(VAR2,3)+16*REF(VAR2,4)+15*REF(VAR2,5)+14*REF(VAR2,6)+13*REF(VAR2,7)+12*REF(VAR2,8)+11*REF(VAR2,9)+10*REF(VAR2,10)+9*REF(VAR2,11)+8*REF(VAR2,12)+7*REF(VAR2,13)+6*REF(VAR2,14)+5*REF(VAR2,15)+4*REF(VAR2,16)+3*REF(VAR2,17)+2*REF(VAR2,18)+REF(VAR2,20))/210,COLORWHITE; KTX: MA(DTX,10), COLORYELLOW; STICKLINE(DTX>KTX,DTX,KTX, COLORRED,10); STICKLINE(DTX<KTX,DTX,KTX, COLORGREEN,10) ;STICKLINE(CLOSE>=OPEN,OPEN,CLOSE, COLORRED,1);DRAWLINE(CLOSE>=OPEN,HIGH, CLOSE>=OPEN,CLOSE, COLORRED);DRAWLINE(CLOSE>=OPEN,LOW, CLOSE>=OPEN,OPEN, COLORRED);STICKLINE(CLOSE<OPEN,OPEN,CLOSE, COLORGREEN,0);DRAWLINE(CLOSE<OPEN,HIGH, CLOSE<OPEN,LOW, COLORGREEN);MU:MA(CLOSE,60),COLORBLUE;MH:MA(CLOSE,360),COLORMAGENTA;龙出沧海VAR2:=(3*CLOSE+LOW+OPEN+HIGH)/6;DTX:(20*VAR2+19*REF(VAR2,1)+18*REF(VAR2,2)+17*REF(VAR2,3)+16*REF(VAR2,4)+15*REF(VAR2,5)+14*REF(VAR2,6)+13*REF(VAR2,7)+12*REF(VAR2,8)+11*REF(VAR2,9)+10*REF(VAR2,10)+9*REF(VAR2,11)+8*REF(VAR2,12)+7*REF(VAR2,13)+6*REF(VAR2,14)+5*REF(VAR2,15)+4*REF(VAR2,16)+3*REF(VAR2,17)+2*REF(VAR2,18)+REF(VAR2,20))/210,COLORWHITE;KTX: MA(DTX,10), COLORYELLOW;STICKLINE(DTX>KTX,DTX,KTX, COLORLIGHTRED,10);STICKLINE(DTX<KTX,DTX,KTX, COLORBLUE,10) ;STICKLINE(CLOSE>=OPEN,OPEN,CLOSE, COLORRED,1);DRAWLINE(CLOSE>=OPEN,HIGH, CLOSE>=OPEN,CLOSE, COLORRED);DRAWLINE(CLOSE>=OPEN,LOW, CLOSE>=OPEN,OPEN, COLORRED);STICKLINE(CLOSE<OPEN,OPEN,CLOSE, COLORGREEN,0);DRAWLINE(CLOSE<OPEN,HIGH, CLOSE<OPEN,LOW, COLORGREEN);两个指标Y:=(HIGH+LOW)/2;AO:MA(Y ,5 )-MA(Y ,34 ),COLORWHITE;AO1:=REF(AO,1);AC:AO-MA( AO,5),COLORYELLOW;A:0.99*(AO+AC)/2,COLORRED;AC1:=REF(AC,1);STICKLINE(AO>0&&AC>0,0,AO+AC,COLORRED,0);STICKLINE(AO<0&&AC>0,0,AO,COLORWHITE,1);STICKLINE(AO<0&&AC>0,0,AO+AC,COLORWHITE,0);STICKLINE(AO>0&&AC<0,0,AO,COLORRED,1);STICKLINE(AO>0&&AC<0,0,AC+AO,COLORRED,0);STICKLINE(AO<0&&AC<0,0,AC+AO,COLORWHITE,0);俩条飘带C:=CLOSE;HZ:=EMA(CLOSE,13);DB:EMA(HZ,1),COLORWHITE;ZB:EMA(HZ,26),COLORMAGENTA;JX148:=EMA(C,148);HZ2:EMA(HZ,8),COLORGREEN;HZ4:EMA(HZ,39),COLORMAGENTA;FILLRGN(DB>HZ2,DB,HZ2,COLORGREEN);FILLRGN(DB<HZ2,DB,HZ2,COLORWHITE);FILLRGN(ZB>HZ4,ZB,HZ4,COLORMAGENTA);FILLRGN(ZB<HZ4,ZB,HZ4,COLORBLUE);可以变色K线MID:=MA(CLOSE,20);UPPER:=MID+2*STD(CLOSE,20);LOWER:=MID-2*STD(CLOSE,20);V1:=(CLOSE-LOWER)/(UPPER-LOWER)*100;V2:=V1-EMA(V1,5);K1:=SUM(LLV(V2,4),4)/4;V3:=EMA(V2,64)*10;V4:=EMA(0.4*V2*(-1),3);V5:=-1*EMA(V2,39)*10;A:=V3>10;B:=V2>V4;D:=V5>10;E:=V3<=10||V2<=V4||V5<=10;KS:=(CLOSE-SMA(CLOSE,13,1))/SMA(CLOSE,13,1)*(-100);RKS:=REF(KS,1);MLS:=RKS/KS>1.23 && RKS>13 && CLOSE/REF(CLOSE,1)>1.03;DRAWLINE(CLOSE>=OPEN && E,HIGH,CLOSE>=OPEN && E,LOW,COLORRED);STICKLINE(CLOSE>=OPEN && E,CLOSE,OPEN,COLORRED,0);DRAWLINE(CLOSE< OPEN && E,HIGH,CLOSE< OPEN && E,LOW,COLORGREEN);STICKLINE(CLOSE< OPEN && E,CLOSE,OPEN,COLORGREEN,0);DRAWLINE(OPEN> CLOSE && A,LOW,OPEN> CLOSE && A,HIGH,COLORYELLOW);STICKLINE(OPEN> CLOSE && A,CLOSE,OPEN,COLORYELLOW,0);DRAWLINE(OPEN<=CLOSE && A,LOW,OPEN<=CLOSE && A,HIGH,COLORYELLOW);STICKLINE(OPEN<=CLOSE && A,CLOSE,OPEN,COLORYELLOW,1);DRAWLINE(OPEN> CLOSE && B,LOW,OPEN> CLOSE && B,HIGH,COLORRED);STICKLINE(OPEN> CLOSE && B,CLOSE,OPEN,COLORRED,0);DRAWLINE(OPEN<=CLOSE && B,LOW,OPEN<=CLOSE && B,HIGH,COLORRED);STICKLINE(OPEN<=CLOSE && B,CLOSE,OPEN,COLORRED,1);DRAWLINE(OPEN> CLOSE && D,LOW,OPEN> CLOSE && D,HIGH,COLORGREEN);STICKLINE(OPEN> CLOSE && D,CLOSE,OPEN,COLORGREEN,0);DRAWLINE(OPEN<=CLOSE && D,LOW,OPEN<=CLOSE && D,HIGH,COLORGREEN);STICKLINE(OPEN<=CLOSE && D,CLOSE,OPEN,COLORGREEN,1);DRAWLINE(KS>13,HIGH,KS>13,LOW,COLORWHITE);DRAWLINE(MLS=1,HIGH,MLS=1,LOW,COLORMAGENTA);STICKLINE(KS>13,OPEN,CLOSE,COLORWHITE,1);STICKLINE(MLS=1,OPEN,CLOSE,COLORMAGENTA,1);HH:=HHV(HIGH,N);LL:=LLV(LOW,N);HH1:=BARSLAST((HH > REF(HH,1)));LL1:=BARSLAST((LL < REF(LL,1)));DRAWTEXT(CROSS(HH1,LL1),HH,'开空');DRAWTEXT(CROSS(LL1,HH1),LL,'开多');T:=IF(HH1>LL1,1,-1);G:=IF(HH1>LL1,HH,LL);DRAWLINE(T=1&&REF(T,1)=1,G,T=1&&REF(T,1)=1,REF(G,1),COLORCYAN);DRAWLINE(T=-1&&REF(T,1)=-1,G,T=-1&&REF(T,1)=-1,REF(G,1),COLORRED);DRAWSL(T=1,G,0,1,0,COLORCYAN);DRAWSL(T=-1,G,0,1,0,COLORRED);N=10考夫曼的ama-自适应移动平均线交易指标:DIRECTION:=CLOSE-REF(CLOSE,N);VOLATILITY:=SUM(ABS((CLOSE-REF(CLOSE,1))),N);ER:=ABS(DIRECTION/VOLATILITY);FASTSC:=2/(2 + 1);SLOWSC:=2/(30 + 1);SSC:=ER*(FASTSC-SLOWSC)+SLOWSC;CONSTANT:=SSC*SSC;AMAHIGH:REF(EMA(HIGH,N),1)+CONSTANT*(HIGH- REF(EMA(HIGH,N),1));AMALOW:REF(EMA(LOW,N),1)+CONSTANT*(LOW- REF(EMA(LOW,N),1));参数N的数值自己定义

考夫曼的ama-自适应移动平均线交易模型:DIRECTION:=CLOSE-REF(CLOSE,N);VOLATILITY:=SUM(ABS((CLOSE-REF(CLOSE,1))),N);ER:=ABS(DIRECTION/VOLATILITY);FASTSC:=2/(2 + 1);SLOWSC:=2/(30 + 1);SSC:=ER*(FASTSC-SLOWSC)+SLOWSC;CONSTANT:=SSC*SSC;AMAHIGH:=REF(EMA(HIGH,N),1)+CONSTANT*(HIGH- REF(EMA(HIGH,N),1));AMACLOSE:=REF(EMA(CLOSE,N),1)+CONSTANT*(CLOSE- REF(EMA(CLOSE,N),1));AMALOW:=REF(EMA(LOW,N),1)+CONSTANT*(LOW- REF(EMA(LOW,N),1));LOW>AMAHIGH,BK;CLOSE<AMACLOSE,SP;HIGH<AMALOW,SK;CLOSE>AMACLOSE,BP;开空开多HH:=HHV(HIGH,N);LL:=LLV(LOW,N);HH1:=BARSLAST((HH>REF(HH,1)));LL1:=BARSLAST((LL<REF(LL,1)));A:=IF((HH1 < LL1),1,IF((HH1 > LL1),-1,0));IF(A>=0,LL,HH),COLORYELLOW;STICKLINE((HH1 < LL1),CLOSE,OPEN,COLORRED,0);DRAWLINE((HH1 < LL1),HIGH,(HH1<LL1),LOW,COLORRED);STICKLINE((HH1 > LL1),CLOSE,OPEN,COLORBLUE,0);DRAWLINE((HH1 > LL1),HIGH,(HH1 > LL1),LOW,COLORBLUE);DRAWTEXT(CROSS(HH1,LL1),HH,'开空');DRAWTEXT(CROSS(LL1,HH1),LL,'开多');N=15,N=10决战MACDVAR1:=((EMA(CLOSE,12) - EMA(CLOSE,26)) * 100);VAR2:=EMA(VAR1,9);VAR3:=(2 * (VAR1 - VAR2));FILLRGN((VAR1 >= 0),0,(VAR1 * 0.8),COLORRED);FILLRGN((VAR1 >= 0),0,(VAR1 * 0.7),COLORMAGENTA);FILLRGN((VAR1 >= 0),0,(VAR1 * 0.6),COLORYELLOW);FILLRGN((VAR1 >= 0),0,(VAR1 * 0.5),COLORGREEN);FILLRGN((VAR1 >= 0),0,(VAR1 * 0.4),COLORBLUE);FILLRGN((VAR1 >= 0),0,(VAR1 * 0.3),COLORLIGHTGREEN);FILLRGN((VAR1 >= 0),0,(VAR1 * 0.2),COLORLIGHTBLUE);FILLRGN((VAR1 >= 0),0,(VAR1 * 0.1),COLORCYAN);FILLRGN((VAR1 < 0),0,(VAR1 * 0.8),COLORRED);FILLRGN((VAR1 < 0),0,(VAR1 * 0.7),COLORMAGENTA);FILLRGN((VAR1 < 0),0,(VAR1 * 0.6),COLORYELLOW);FILLRGN((VAR1 < 0),0,(VAR1 * 0.5),COLORGREEN);FILLRGN((VAR1 < 0),0,(VAR1 * 0.4),COLORBLUE);FILLRGN((VAR1 < 0),0,(VAR1 * 0.3),COLORLIGHTGREEN);FILLRGN((VAR1 < 0),0,(VAR1 * 0.2),COLORLIGHTBLUE);FILLRGN((VAR1 < 0),0,(VAR1 * 0.1),COLORCYAN);FILLRGN((VAR2 >= 0),0,(VAR2 * 0.8),COLORRED);FILLRGN((VAR2 >= 0),0,(VAR2 * 0.7),COLORMAGENTA);FILLRGN((VAR2 >= 0),0,(VAR2 * 0.6),COLORYELLOW);FILLRGN((VAR2 >= 0),0,(VAR2 * 0.5),COLORGREEN);FILLRGN((VAR2 >= 0),0,(VAR2 * 0.4),COLORBLUE);FILLRGN((VAR2 >= 0),0,(VAR2 * 0.3),COLORLIGHTGREEN);FILLRGN((VAR2 >= 0),0,(VAR2 * 0.2),COLORLIGHTBLUE);FILLRGN((VAR2 >= 0),0,(VAR2 * 0.1),COLORCYAN);FILLRGN((VAR2 < 0),0,(VAR2 * 0.8),COLORRED);FILLRGN((VAR2 < 0),0,(VAR2 * 0.7),COLORMAGENTA);FILLRGN((VAR2 < 0),0,(VAR2 * 0.6),COLORYELLOW);FILLRGN((VAR2 < 0),0,(VAR2 * 0.5),COLORGREEN);FILLRGN((VAR2 < 0),0,(VAR2 * 0.4),COLORBLUE);FILLRGN((VAR2 < 0),0,(VAR2 * 0.3),COLORLIGHTGREEN);FILLRGN((VAR2 < 0),0,(VAR2 * 0.2),COLORLIGHTBLUE);FILLRGN((VAR2 < 0),0,(VAR2 * 0.1),COLORCYAN);金融天娇赢利公式参数:n1 21;n2 7;X1:=HHV(HIGH,N1);X2:=LLV(LOW,N2);D1:(X1+X2*2)/3,COLORGREEN;TMP:=D1-CLOSE;DRAWLINE(TMP>0.00001,HIGH,TMP>0.00001,OPEN,COLORCYAN);DRAWLINE(TMP>0.00001,LOW,TMP>0.00001,CLOSE,COLORCYAN);DRAWLINE(TMP<-0.00001,HIGH,TMP<-0.00001,CLOSE,COLORRED);DRAWLINE(TMP<-0.00001,LOW,TMP<-0.00001,OPEN,COLORRED);DRAWLINE(ABS(TMP)<0.00001,LOW,ABS(TMP)<0.00001,OPEN,COLORWHITE);DRAWLINE(ABS(TMP)<0.00001,HIGH,ABS(TMP)<0.00001,OPEN,COLORWHITE);STICKLINE(TMP>0.00001,OPEN,CLOSE,COLORCYAN,1);STICKLINE(TMP<-0.00001,OPEN,CLOSE,COLORRED,1);金龙行天下C:=CLOSE;L:=LOW;H:=HIGH;O:=OPEN;RSV:=(C-LLV(L,7))/(HHV(H,7)-LLV(L,7))*100;RSV1:=(C-LLV(L,38))/(HHV(H,38)-LLV(L,38))*100;LJ:SMA(RSV1,5,1),COLORWHITE;SY:SMA(LJ,10,1),COLORYELLOW;FILLRGN(LJ<=SY,LJ,SY,COLORGREEN);FILLRGN(LJ>=SY,SY,LJ,COLORRED);A:=(3*C+L+O+H)/6;VAR2Q:=MA(C,80)-MA(C,13)/3;SQX:=MA((C-VAR2Q)/VAR2Q,1);XA:=EMA(SQX,12)*0.7;XB:=EMA(SQX,3);DBQY:IF(LLV(XB-XA,12)>0,0,-15),COLORBLUE;DIFF:=(EMA(C,17)-EMA(C,73))*100;DEA:=EMA(DIFF,73);MACD:=2*(DIFF-DEA);STICKLINE(DIFF<=0 && DEA<=DIFF && REF(DIFF,1)<REF(DEA,1),3,26,COLORCYAN,0);IF(DIFF<=0 && DEA<=DIFF && REF(DIFF,1)<REF(DEA,1),10,0),COLORMAGENTA;胶实测年收益达176%的模型(胶30分线)MA5:=MA(CLOSE,5);MA10:=MA(CLOSE,10);MA40:=MA(CLOSE,40);MA80:=MA(CLOSE,80);CROSS(MA5,MA10) {5均线上穿10均线且均线成多头排列,买平买开}&&MA10>REF(MA10,1)&&REF(MA10,1)>REF(MA10,2)&&MA5>REF(MA5,1)&&REF(MA5,1)>REF(MA5,2),BPK;CROSS(MA10,MA5) {5均线下穿10均线且均线成空头排列,卖平卖开}&&MA10<REF(MA10,1)&&REF(MA10,1)<REF(MA10,2)&&MA5<REF(MA5,1)&&REF(MA5,1)<REF(MA5,2),SPK;自已做的模型,目的在于和大家交流,希望志同道合者回贴。发表自已的观点和看法。江太短线升级系M1:=MA(CLOSE,5);M2:MA(CLOSE,20),COLORYELLOW;ZYZS:IF((M1 > M2),M2,M1),COLORGREEN;PARTLINE(ZYZS > REF(ZYZS,1) && ZYZS = M2,ZYZS,COLORGREEN);D:=(SMA(CLOSE,SHORT,X) > SMA(CLOSE,LONG,X));K:=(SMA(CLOSE,SHORT,X) < SMA(CLOSE,LONG,X));Z:=CLOSE >=OPEN;Y:=CLOSE < OPEN;STICKLINE(K && Z,OPEN,CLOSE,COLORGREEN,1);DRAWLINE(K && Z,HIGH, K && Z,CLOSE,COLORGREEN);DRAWLINE(K && Z,LOW, K && Z,OPEN,COLORGREEN);STICKLINE(K && Y,OPEN,CLOSE,COLORGREEN,0);DRAWLINE(K && Y,HIGH, K && Y,LOW,COLORGREEN);STICKLINE(D && Z,OPEN,CLOSE,COLORRED,1);DRAWLINE(D && Z,HIGH, D && Z,CLOSE,COLORRED);DRAWLINE(D && Z,LOW, D && Z,OPEN,COLORRED);STICKLINE(D && Y,OPEN,CLOSE,COLORRED,0);DRAWLINE(D && Y,HIGH, D && Y,LOW,COLORRED);见好跑VAR3:=(CLOSE-LLV(LOW,26))/(HHV(HIGH,26)-LLV(LOW,26))*100;VAR4:=SMA(SMA(VAR3,3,1),3,1);VAR5:=EMA(VAR4,5);VAR6:=VAR5;VAR7:=3*VAR4-2*VAR5;VAR8:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;K: SMA(VAR8,3,1);D: SMA(K,3,1);VAR9:=3*K-2*D;VARA:=LLV(LOW,36);VARB:=HHV(HIGH,30);VARC:=EMA((CLOSE-VARA)/(VARB-VARA)*4,4)*25;QUSHI: VARC, COLORGREEN;STICKLINE(VARC<10,0,8,COLORYELLOW,0);STICKLINE(VARC>90,100,92,COLORBLUE,0);VARD:=87.5;VARE:=(VARC-LLV(VARC,4))/(HHV(VARC,4)-LLV(VARC,4))*4*25;DRAWTEXT(IF(CROSS(VAR9,8),87,0),48,'反弹');DRAWTEXT(IF(CROSS(VARE,87.5) && QUSHI<40,87,0),10,'买');DRAWTEXT(IF(CROSS(QUSHI,VARD) && VARE=100,50,0),56,'目标位');DRAWTEXT(IF(CROSS(VARD,QUSHI),87,0),85,'见好跑');DRAWTEXT(IF(CROSS(QUSHI,VARE) && QUSHI>87,87,0),70,'卖');VARF:=SMA(VAR3,20,1);VAR10:=SMA(VARF,15,1);VAR11:=(3*VARF+2*VAR10)/4;VAR12:=REF(VAR11,1);VAR13:=SMA(MAX(VAR11-VAR12,0),2,1)/SMA(ABS(VAR11-VAR12),2,1)*100;VAR14:=MA(VAR13,10);VAR15:=IF(CROSS(VAR14,90),25,0);DRAWTEXT(CROSS(VAR14,90),27,'强势整理');STICKLINE((CROSS(QUSHI,10) && QUSHI>10),0,30, COLORRED,0);VAR16:=(CLOSE+LOW+HIGH)/3;VAR17:=SUM((VAR16-REF(LOW,1)-(HIGH-VAR16))*VOL/100000/(HIGH-LOW),0);VAR18:=EMA(VAR17,1);VAR19:=MA(VAR18,12);VAR1A:=MA(VAR18,26);VAR1B:=(VAR18-VAR19)*10;VAR1C:=OPI/EMA(VOL,5)/30*1.1;VAR1D:=IF(CROSS(VAR1B,VAR1C),1,0);极品均线VAR1:=(CLOSE-MA(CLOSE,21))/MA(CLOSE,21)*100;VAR2:=EMA(VAR1,13);VAR3:=REF(VAR2,1);STICKLINE(VAR2>=VAR3,VAR3,VAR2,COLORRED,1);STICKLINE(VAR3>VAR2,VAR2,VAR3,COLORCYAN,0);MA1:MA(VAR2,3),COLORWHITE;MA2:MA(VAR2,7),COLORYELLOW;MA3:MA(VAR2,9),COLORGREEN;MA4:MA(VAR2,18),COLORRED;火焰之王-空VAR1:=EMA(HHV(HIGH,500),21);VAR2:=EMA(HHV(HIGH,250),21);VAR3:=EMA(HHV(HIGH,90),21);VAR4:=EMA(LLV(LOW,500),21);VAR5:=EMA(LLV(LOW,250),21);VAR6:=EMA(LLV(LOW,90),21);VAR7:=EMA((((((((VAR4 * 0.96) + (VAR5 * 0.96)) + (VAR6 * 0.96)) + (VAR1 * 0.558)) + (VAR2 * 0.558)) + (VAR3 * 0.558)) / 6),21);VAR8:=EMA((((((((VAR4 * 1.25) + (VAR5 * 1.23)) + (VAR6 * 1.2)) + (VAR1 * 0.55)) + (VAR2 * 0.55)) + (VAR3 * 0.65)) / 6),21);VAR9:=EMA((((((((VAR4 * 1.3) + (VAR5 * 1.3)) + (VAR6 * 1.3)) + (VAR1 * 0.68)) + (VAR2 * 0.68)) + (VAR3 * 0.68)) / 6),21);VARA:=EMA((((((VAR7 * 3) + (VAR8 * 2)) + VAR9) / 6) * 1.738),21);VARB1:=REF(HIGH,1);VARC1:=((SMA(ABS((HIGH - VARB1)),3,1) / SMA(MIN((HIGH - VARB1),0),3,1)) * 100);VARD1:=EMA(IF(((CLOSE * 1.35) > VARA),(VARC1 * 10),(VARC1 / 10)),3);VARE1:=LLV(LOW,30);VARF1:=HHV(VARD1,30);VAR10:=IF(MA(CLOSE,58),1,0);HILL:((EMA(IF((LOW >= VARE1),((VARD1 + (VARF1 * 2)) / 2),0),3) / 618) * VAR10);STICKLINE((HILL < 0),0,HILL,COLORRED,1);JL:HILL;STICKLINE((HILL < 0),0,(JL * 1.2),COLORRED,0);STICKLINE((HILL < 0),0,(JL * 0.8),COLORMAGENTA,0);STICKLINE((HILL < 0),0,(JL * 0.6),COLORYELLOW,0);STICKLINE((HILL < 0),0,(JL * 0.4),COLORGREEN,0);STICKLINE((HILL < 0),0,(JL * 0.2),COLORBLUE,0);DRAWTEXT(HILL<= -45,(JL * 1.2),'机会来了!上吧,好好把握这一切');

指标下载地址:

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: