文华财经仓量和波段王指标

  • A+
所属分类:文华公式

指标代码及说明:

文华财经仓量和波段王指标

网上找来的文华仓量指标以及文华主图波段王指标

仓量王

N1 :125 N2 :5 N3:20

NN:=BARSLAST(DATE<>REF(DATE,1))+1;

KH:=HHV(NN,300);

VERTLINE(DATE<>REFX(DATE,1)&&ISLASTBAR<>1&&KH<>1,COLORBLUE);

QQ:=OPI-REF(OPI,1);

K1:=IFELSE(CLOSE>OPEN&&QQ>=0,QQ,0);

KK1:=IFELSE(CLOSE<OPEN&&QQ<0,QQ,0);

KKK1:=IFELSE(CLOSE=OPEN,QQ*0.5,0);

K2:=IFELSE(CLOSE<OPEN&&QQ>=0,QQ,0);

KK2:=IFELSE(CLOSE>OPEN&&QQ<0,QQ,0);

DO:=SUM(K1,NN)+SUM(KK1,NN)+SUM(KKK1,NN);

KO:=SUM(K2,NN)+SUM(KK2,NN)+SUM(KKK1,NN);

N4:=IFELSE(NN<=4,NN,4);

VK1:=IFELSE(CLOSE>=OPEN,VOL,0);

VK2:=IFELSE(CLOSE<=OPEN,VOL,0);

VDO:=SUM(VK1,N4);

VKO:=SUM(VK2,N4);

VDK:=VDO-VKO;

CC:=SUM(QQ,NN);

DRAWNUMBER(ISLASTBAR&&CC>0,0,CC,0,COLORMAGENTA);

DRAWNUMBER(ISLASTBAR&&CC<0,0,CC,0,COLORBLUE);

POLYLINE(CLOSE>0,DO,COLORRED);

POLYLINE(CLOSE>0,KO,COLORGREEN);

W:=MOD(NN,5);

J:=BACKSET(ISLASTBAR,5);

DRAWNUMBER(ISLASTBAR,DO,DO,0,COLORYELLOW);

DRAWNUMBER(ISLASTBAR,KO,KO,0,COLORGREEN);

DRAWNUMBER(W=0&&J=0,DO,DO,0,COLORYELLOW);

DRAWNUMBER(W=0&&J=0,KO,KO,0,COLORGREEN);

波段王

N1 =125,N2 =5,N3=20

HX:=HHV(HIGH,3);

LX:=LLV(LOW,3);

H1:=IFELSE(HX<REF(HX,1)&&HX<REF(HX,2)&&HX<REF(HX,4)&&LX<REF(LX,1)&&LX<REF(LX,3)&&LX<REF(LX,5)&&OPEN>CLOSE&&(HHV(OPEN,0)-CLOSE)>0,REF(HX,4),0);

L1:=IFELSE(LX>REF(LX,1)&&LX>REF(LX,3)&&LX>REF(LX,5)&&HX>REF(HX,1)&&HX>REF(HX,2)&&HX>REF(HX,4)&&OPEN<CLOSE&&(CLOSE-LLV(OPEN,0))>0,REF(LX,4),0);

H2:=VALUEWHEN(H1>0,H1);

L2:=VALUEWHEN(L1>0,L1);

K1:=IFELSE(CLOSE>H2,-3,IFELSE(CLOSE<L2,1,0));K2:=VALUEWHEN(K1<>0,K1);G:=IFELSE(K2=1,H2,L2);

G1:=VALUEWHEN(ISLASTBAR,G);DRAWNUMBER(LX>0,G1,G1,0,COLORCYAN);

TMP:=K2;W1:=K2;

W2:=OPEN-CLOSE;

HT:=IFELSE(OPEN>CLOSE,OPEN,CLOSE);

LT:=IFELSE(OPEN<CLOSE,OPEN,CLOSE);

DRAWLINE(W1=1,HIGH,W1=1,HT,COLORCYAN);

DRAWLINE(W1=1,LOW,W1=1,LT,COLORCYAN);

DRAWLINE(W1=-3,HIGH,W1=-3,HT,COLORRED);

DRAWLINE(W1=-3,LOW,W1=-3,LT,COLORRED);

STICKLINE(W1>0,OPEN,CLOSE,COLORCYAN,1);

STICKLINE(W1<=0,OPEN,CLOSE,COLORRED,1);

STICKLINE(W2>0&&W1<=0,OPEN,CLOSE,COLORRED,0);

STICKLINE(W2>0&&W1>0,OPEN,CLOSE,COLORCYAN,0);

DRAWLINE(TMP=1&&REF(TMP,1)=1,G,TMP=1&&REF(TMP,1)=1,REF(G,1),COLORCYAN);DRAWLINE(TMP=-3&&REF(TMP,1)=-3,G,TMP=-3&&REF(TMP,1)=-3,REF(G,1),COLORRED);DRAWSL(K2=1,G,0,1,0,COLORCYAN);DRAWSL(K2=-3,G,0,1,0,COLORRED);

DRAWTEXT(CROSS(TMP,0),HX,'卖');

DRAWTEXT(CROSS(0,TMP),LX,'买');

MA55:=MA(CLOSE,55);

DRAWTEXT(CROSS(TMP,0)&&CLOSE<=MA55,HX,'卖↓');

DRAWTEXT(CROSS(0,TMP)&&CLOSE>=MA55,LX,'买↑');

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: